Our wait times are a little bit longer than usual at the moment.
Incident Report for Monzo Bank
Resolved
This incident has been resolved.
Posted Dec 08, 2018 - 12:23 UTC
Update
We're working hard to answer your questions as soon as possible, and we're growing the team rapidly to get us back up to speed. In the meantime it might take us a little while to get back to you.

If it's urgent and you really need help as soon as possible, make sure to flick the urgent switch on – that lets us know to prioritise your message πŸ‘
Posted Nov 16, 2018 - 18:22 UTC
Monitoring
We're working hard to answer your questions as soon as possible, and we're growing the team rapidly to get us back up to speed. In the meantime it might take us a little while to get back to you.

If it's urgent and you really need help as soon as possible, make sure to flick the urgent switch on – that lets us know to prioritise your message πŸ‘
Posted Nov 16, 2018 - 18:22 UTC
This incident affected: βœ‰οΈ Email Support.