We were experiencing some issues at the moment with verifying online payments
Incident Report for Monzo Bank
Resolved
Services are available again, this issue is over. Customers were unable to approve payments made online, and Monzo.me links were not available. Other banking functions are working normally.
Posted Jun 21, 2022 - 07:45 UTC
Monitoring
Services are available again, we're continuing to monitor closely. Customers were unable to approve payments made online, and Monzo.me links were not available. Other banking functions are working normally.
Posted Jun 21, 2022 - 07:13 UTC
Investigating
Customers are currently unable to approve payments made online, and Monzo.me links are not available. Other banking functions are working normally. We are investigating with our network providers and will provide more updates soon.
Posted Jun 21, 2022 - 06:59 UTC