Some calls are dropping out or not connecting

Incident Report for Monzo Bank

Resolved

Our phone lines should be back to normal. We'll keep an eye on things, and sorry if it caused you any problems!
Posted Aug 19, 2020 - 17:20 UTC

Identified

Our phone lines are having some trouble, and some calls aren't connecting properly. If it's urgent but you can't get through, please chat to us in the app or try the phone again. We're working on a fix as fast as we can.
Posted Aug 19, 2020 - 15:55 UTC