We're experiencing some issues sending outbound international payments
Incident Report for Monzo Bank
Resolved
The earlier problems affecting outbound international payments are now fixed 🎉 Everything should be back to normal, but let us know if you experience anything unusual.
Posted Nov 01, 2022 - 14:47 UTC
Investigating
We've observed that outbound international payments might not be being sent successfully. We're currently investigating.
Posted Nov 01, 2022 - 13:40 UTC
This incident affected: 💸 Outbound Bank Transfers.