Calls impacted due to third party outage.
Incident Report for
Monzo Bank
Resolved
The issue has now been resolved and all call operations are back to normal.
Posted
Nov
25
,
2025
-
16:06
UTC
Investigating
An outage with one of our third party is impacting phone calls. Please contact us on chat instead.
Posted
Nov
25
,
2025
-
15:25
UTC
This incident affected: ☎️ Phone Support.
×
Subscribe to Incident
Subscribe to updates for
Calls impacted due to third party outage.
via . You'll receive .