We've fixed the earlier problems with chat and calls. Everything's back to normal.
Incident Report for Monzo Bank
Resolved
We are sorry about the inconvenience this may have caused. Everything should be back to normal now.
Posted Feb 14, 2020 - 15:33 UTC
Investigating
We're currently investigating an issue with chat and calls at the moment and will update the status page as soon as we can.
Posted Feb 14, 2020 - 15:04 UTC