Bank transfers delayed
Incident Report for Monzo Bank
Resolved
We've fixed the problem affecting inbound and outbound bank transfers - all delayed payments have now arrived
Posted Dec 05, 2018 - 12:44 UTC
Investigating
We're investigating an issue causing inbound and outbound bank transfers to be delayed, we expect this to be resolved in a few minutes.
Posted Dec 05, 2018 - 12:37 UTC
This incident affected: 💰 Inbound Bank Transfers and 💸 Outbound Bank Transfers.