We're identified an issue impacting payments at the moment
Incident Report for Monzo Bank
Resolved
The issue is now resolved
Posted Jun 12, 2023 - 17:18 UTC
Investigating
We've identified a third party issue impacting card payments. When you try to use your card it may not work. We are working with partners to fix this issue.
Posted Jun 12, 2023 - 16:36 UTC