We're experiencing some issues at the moment
Incident Report for Monzo Bank
Resolved
We’ve resolved issues with the Monzo app, payments and chat. We’re continuing to keep an eye on them.

Response times for your chat may be delayed while we get back to everyone
Posted Feb 20, 2020 - 03:38 UTC
Monitoring
We’ve resolved issues with the Monzo app, payments and chat. We’re continuing to keep an eye on them.

Response times for your chat may be delayed while we get back to everyone
Posted Feb 20, 2020 - 03:04 UTC
Investigating
At the moment, we're investigating issues with the Monzo app and chat. You may not be able to log in to the Monzo app, and payments might fail. We're working to fix it as soon as possible. (edited)
Posted Feb 20, 2020 - 02:07 UTC