We're experiencing longer than usual chat wait times at the moment
Incident Report for Monzo Bank
Resolved
The longer than usual wait times have been resolved. In-app chat now has usual wait times.
Posted Dec 23, 2020 - 14:46 UTC
Investigating
We're currently experiencing longer than usual wait times for in-app chat. If your issue is not urgent, please consider coming back later.
Posted Dec 23, 2020 - 10:16 UTC