Bank transfers delayed
Incident Report for Monzo Bank
Resolved
This incident has been resolved.
Posted Oct 20, 2018 - 22:13 UTC
Monitoring
The issue has been fixed and any delayed payments should start showing in your account shortly.
Posted Oct 20, 2018 - 22:01 UTC
Update
Payments made to Monzo accounts will be delayed. Payments from Monzo to other banks are unaffected.
Posted Oct 20, 2018 - 20:54 UTC
Update
We are continuing to investigate this issue.
Posted Oct 20, 2018 - 20:26 UTC
Investigating
We’re currently investigating issues causing delays to bank transfers.
Posted Oct 20, 2018 - 20:24 UTC
This incident affected: 💰 Inbound Bank Transfers and 💸 Outbound Bank Transfers.