Some Inbound Payments Delayed

Incident Report for Monzo Bank

Resolved

This incident has been resolved.
Posted Sep 06, 2018 - 02:11 UTC

Update

We're currently experiencing an issue with some inbound payments (paid via Direct Credit) not being added to a few accounts. We're working to fix the problem as soon as possible & will keep you updated. Thanks for your patience!
Posted Sep 06, 2018 - 01:44 UTC

Update

We are continuing to investigate this issue.
Posted Sep 06, 2018 - 01:44 UTC

Update

We're currently experiencing an issue with some inbound payments (paid via Direct Credit) not being added to a few accounts. We're working to fix the problem as soon as possible & will keep you updated. Thanks for your patience!
Posted Sep 06, 2018 - 01:38 UTC

Investigating

We're currently experiencing an issue meaning that some inbound payments (paid via BACS) may not have been added to your account. We're working to fix the problem as soon as possible and will keep you updated. Thanks so much for your patience!
Posted Sep 06, 2018 - 01:25 UTC