Bank transfers delayed
Incident Report for Monzo Bank
Resolved
All delayed bank transfers have been delivered and there are no further delays to bank transfers. Thank you for your patience during these delays.
Posted Nov 09, 2018 - 18:23 UTC
Monitoring
We are now delivering delayed bank transfers. They should arrive in the next few minutes.
Posted Nov 09, 2018 - 18:21 UTC
Identified
Some bank transfers are currently delayed. If you've made a payment to or from a Monzo account, your payment will not be delivered immediately but should come through within the next hour. Please avoid trying bank transfers again. We're sorry for the inconvenience from this.
Posted Nov 09, 2018 - 18:01 UTC
This incident affected: 💰 Inbound Bank Transfers and 💸 Outbound Bank Transfers.