Some payments may fail. We're investigating

Incident Report for Monzo Bank

Resolved

All card transactions are being processed as normal. The problem was external to Monzo and has been resolved, but we will be keeping a close eye
Posted Oct 29, 2018 - 20:07 UTC

Investigating

We're currently investigating an issue where some card payments are failing. We will keep you up to date when we have new information.
Posted Oct 29, 2018 - 19:34 UTC
This incident affected: 💳 Card Payments.