Delays to bank transfers
Incident Report for Monzo Bank
Resolved
Bank transfers are now working as expected. We're sorry for the inconvenience this caused - thanks for your patience
Posted Sep 26, 2018 - 11:14 UTC
Monitoring
Bank transfers should now be working as expected, but we're monitoring the situation and will keep you updated 👍
Posted Sep 26, 2018 - 08:57 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Sep 26, 2018 - 07:51 UTC
Update
We are continuing to investigate this issue.
Posted Sep 26, 2018 - 07:42 UTC
Investigating
We're currently investigating issues with bank transfers - incoming and outgoing payments may be delayed.
Posted Sep 26, 2018 - 07:41 UTC
This incident affected: 💰 Inbound Bank Transfers and 💸 Outbound Bank Transfers.