Response times longer than usual
Incident Report for Monzo Bank
Resolved
This incident has been resolved.
Posted Oct 18, 2018 - 12:52 UTC
Update
We are continuing to work on a fix for this issue.
Posted Oct 07, 2018 - 09:03 UTC
Identified
It may take us significantly longer than normal to reply, as we're seeing higher demand for support than usual. We're really sorry about this 😔

We'd recommend checking out the Help section, as you might find that you're able to find an answer to your question quicker there.

As ever, if your question's urgent, we'll be back to you as soon as we can. In the meantime, we really appreciate your patience 🙏
Posted Oct 07, 2018 - 09:01 UTC
This incident affected: ✉️ Email Support.