Issues with Barclays sending and receiving payments
Incident Report for
Monzo Bank
Resolved
The issue is now resolved.
Posted
Jul
27
,
2026
-
17:53
UTC
Monitoring
We're seeing signs of recovery and are monitoring the situation.
Posted
Jul
27
,
2026
-
16:25
UTC
This incident affected: 💸 Outbound Bank Transfers.
×
Subscribe to Incident
Subscribe to updates for
Issues with Barclays sending and receiving payments
via . You'll receive .