We're experiencing issues receiving customer phone calls
Incident Report for Monzo Bank
Resolved
We're getting all the information we need to fix this and will update the status page as soon as we can.

We recommend using our in-app help and chat, or emailing us at help@monzo.com if you need support.
Posted Feb 18, 2023 - 05:54 UTC
Investigating
We're getting all the information we need to fix this and will update the status page as soon as we can.

We recommend using our in-app help and chat, or emailing us at help@monzo.com if you need support.
Posted Feb 17, 2023 - 13:23 UTC