ClearScore notifications
Incident Report for Monzo Bank
Update
ClearScore is a platform that allows you to access your credit report and shows the data that Equifax has. The reason you’ve received this recent notification is because we’ve recently started reporting to Equifax. You can read more about what we report and why in this blog post: https://monzo.com/blog/monzo-reports-to-all-credit-reference-agencies-cras-equifax-experian-transunion
Posted Nov 05, 2021 - 16:01 UTC
Monitoring
ClearScore is a platform that allows you to access your credit report and shows the data that Equifax has. The reason you’ve received this recent notification is because we’ve recently started reporting to Equifax. You can read more about what we report and why in this blog post: https://monzo.com/blog/monzo-reports-to-all-credit-reference-agencies-cras-equifax-experian-transunion
Posted Oct 29, 2021 - 14:17 UTC