Long support wait times
Incident Report for Monzo Bank
Resolved
This incident has been resolved.
Posted Sep 08, 2018 - 00:10 UTC
Update
We are continuing to work on a fix for this issue.
Posted Sep 08, 2018 - 00:10 UTC
Update
Customer support is really busy at the moment, so it's taking longer than usual to get back to you. We're working really hard to respond as quickly as possible, so please bear with us. Thanks again for your patience!
Posted Sep 05, 2018 - 11:27 UTC
Update
We’ve significantly reduced the time it will take to speak to our customer support team, but it may still take a short while to get back to your query. Thank you again for your continued patience.
Posted Sep 03, 2018 - 19:53 UTC
Update
Our customer support team is experiencing wait times that are longer than usual. We are working hard to answer your questions as soon as we possibly can. Thanks so much for your continued patience!
Posted Sep 03, 2018 - 07:06 UTC
Identified
Our customer support team is experiencing wait times that are longer than usual. We are working hard to answer your questions as soon as we possibly can. Thanks so much for your continued patience!
Posted Sep 01, 2018 - 10:45 UTC