We're having problems with the app, some card payments and bank transfers. We’re working hard to fix it 🛠
Incident Report for Monzo Bank
Resolved
This incident has been resolved.
Posted Nov 28, 2018 - 12:54 UTC
Update
Delayed outbound bank transfers have been sent. We're continuing to fix missing feed items for some customers.
Posted Nov 28, 2018 - 10:11 UTC
Update
We have resolved an issue which was preventing some card payments from working. All delayed inbound bank transfers have been processed. Some outbound transfers may still be delayed and a small number of customers may have missing items in their app feed, we're working to fix these now.
Posted Nov 28, 2018 - 09:45 UTC
Update
We are continuing to work on a fix for this issue.
Posted Nov 28, 2018 - 09:34 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Nov 28, 2018 - 09:34 UTC
This incident affected: 📱 Monzo App, 💳 Card Payments, 💰 Inbound Bank Transfers, and 💸 Outbound Bank Transfers.