Inbound bank transfers are not working temporarily
Incident Report for Monzo Bank
Resolved
Inbound payments are now back to normal.
Posted Jul 21, 2018 - 06:17 UTC
Update
We are continuing to investigate this issue.
Posted Jul 21, 2018 - 06:04 UTC
Investigating
We're currently investigating an issue where inbound bank transfers are not working. We’re working hard to find out what's happening and fix it. We'll keep you updated.
Posted Jul 21, 2018 - 06:03 UTC
This incident affected: 💰 Inbound Bank Transfers.