Bank transfers are delayed
Incident Report for Monzo Bank
Resolved
We have now resolved the issue and all inbound and outbound payments are processing normally. Thank you for your patience and we apologise for any inconvenience.
Posted Aug 16, 2018 - 17:05 UTC
Monitoring
Inbound and outbound bank transfers are currently delayed while we investigate an issue. Sorry for the inconvenience. We will provide updates shortly.
Posted Aug 16, 2018 - 16:39 UTC
This incident affected: 💰 Inbound Bank Transfers and 💸 Outbound Bank Transfers.