Our phones lines have gone down, and we're working to fix them as soon as we can

Incident Report for Monzo Bank

Resolved

This incident has been resolved.
Posted Mar 11, 2025 - 16:37 UTC

Investigating

We're currently investigating the issue, and will provide an update soon.
Posted Mar 11, 2025 - 14:55 UTC