Inbound bank transfers are delayed
Incident Report for Monzo Bank
Resolved
Inbound payments are back to normal.
Posted Jul 21, 2018 - 10:23 UTC
Identified
Incoming bank transfers may take longer than usual to arrive. We are investigating and will update you as soon as we know more.
Posted Jul 21, 2018 - 09:45 UTC
This incident affected: 💰 Inbound Bank Transfers.