We're experiencing some issues at the moment
Incident Report for Monzo Bank
Resolved
The earlier problems are now fixed 🎉 Everything should be back to normal, but let us know if you experience anything unusual.
Posted May 27, 2021 - 16:32 UTC
Monitoring
The earlier problems look to be resolved. Everything should be back to normal, but we're keeping an eye on it to be sure 👀
Posted May 27, 2021 - 15:45 UTC
Identified
We're getting all the information we need to fix this and will update the status page as soon as we can.
Posted May 27, 2021 - 15:33 UTC
Investigating
We're getting all the information we need to fix this and will update the status page as soon as we can.
Posted May 27, 2021 - 15:27 UTC