We're experiencing longer than usual wait times at the moment
Incident Report for Monzo Bank
Resolved
This incident has been resolved.
Posted Aug 10, 2023 - 14:47 UTC
Monitoring
We are particularly busy at the moment, which means customers are having a much longer wait time than normal and we’re really sorry about this. We will answer your chat as soon a possible
Posted Aug 09, 2023 - 17:17 UTC
Update
We are particularly busy at the moment, which means customers are having a much longer wait time than normal and we’re really sorry about this. We will answer your chat as soon a possible
Posted Aug 05, 2023 - 12:14 UTC
Investigating
We are particularly busy at the moment, which means customers are having a much longer wait time than normal and we’re really sorry about this. We will answer your chat as soon a possible
Posted Aug 05, 2023 - 12:13 UTC