Bank transfer delays
Incident Report for Monzo Bank
Resolved
We've fixed the issue, and incoming and outgoing bank transfers should now be arriving as fast as they usually do 🎉

Thanks for sticking with us while we worked on the fix ❤️
Posted Oct 17, 2018 - 12:53 UTC
Identified
We're seeing issues with inbound and outbound bank transfers being delayed - we’re working hard to fix them 🛠️

If you've sent a bank transfer that hasn't arrived yet, there's no need to retry as they will appear once we've fixed the issue. Sorry for the trouble this is causing 😞
Posted Oct 17, 2018 - 12:28 UTC
This incident affected: 💰 Inbound Bank Transfers and 💸 Outbound Bank Transfers.