We're experiencing some issues at the moment
Incident Report for Monzo Bank
Resolved
Things are back to normal now.
Posted Mar 08, 2021 - 20:56 UTC
Monitoring
The issues we've been experiencing with the tools we use to speak to customers have now been resolved, but we're a bit busier than normal so please bear with us and we'll get back to you ASAP. Thanks for your patience.
Posted Mar 08, 2021 - 18:47 UTC
Update
We're experiencing some issues with the tools we use to speak to customers at the moment, so it'll take us longer to get back to your messages - please bear with us. We're also experiencing issues with login. We're working on a fix and will update the status page as soon as we can.
Posted Mar 08, 2021 - 18:29 UTC
Investigating
We're getting all the information we need to fix this and will update the status page as soon as we can.
Posted Mar 08, 2021 - 18:07 UTC