Calls to Monzo may not work
Incident Report for Monzo Bank
Resolved
Phone calls are working again 🙌Thanks for bearing with us!
Posted Aug 13, 2018 - 13:03 UTC
Investigating
We're currently having issues with receiving phone calls for customer support. If you need to get in touch urgently, please contact us via chat in the Help section of the Monzo app
Posted Aug 13, 2018 - 12:56 UTC
This incident affected: ✉️ Email Support.