We're experiencing some issues at the moment
Incident Report for Monzo Bank
Resolved
This incident has been resolved.
Posted Apr 10, 2021 - 12:46 UTC
Monitoring
We are aware of an issue that may have seen you experience a declined payment. We have looked into this and everything should now be up and running again. We apologise for the inconvenience cause.
Posted Apr 10, 2021 - 09:30 UTC