Incoming calls are being missed
Incident Report for Monzo Bank
Resolved
Calls and PIN recoveries are working again - thank you for bearing with us!
Posted Sep 18, 2018 - 12:33 UTC
Update
We will also be unable to process PIN recoveries until this is resolved.
Posted Sep 18, 2018 - 12:16 UTC
Investigating
We are currently unable to answer calls to Monzo - we are investigating and working on a fix for this as soon as possible.

If you need to get in touch urgently, please use the in-app chat. We'll let you know as soon as calls are working again!
Posted Sep 18, 2018 - 12:10 UTC