Transactions may be delayed
Incident Report for Monzo Bank
Resolved
This incident has been resolved.
Posted Aug 16, 2018 - 16:15 UTC
Monitoring
Delayed transactions should be coming through now. We're continuing to monitor the situation.
Posted Aug 16, 2018 - 15:58 UTC
Investigating
We’re experiencing problems and top ups, pot transfers and sending money may be delayed. We’re working hard to fix it as soon as we can, and will continue to post updates.
Posted Aug 16, 2018 - 15:36 UTC
This incident affected: 📱 Monzo App.