Investigating potential issues with new cards
Incident Report for Monzo Bank
Resolved
This incident has been resolved.
Posted Mar 10, 2019 - 11:59 UTC
Monitoring
New cards should be working now, thank you for bearing with us.
Posted Mar 09, 2019 - 18:26 UTC
Investigating
We're investigating reports of cards that arrived today being declined. We'll post updates as we've got them.
Posted Mar 09, 2019 - 16:19 UTC
This incident affected: 💳 Card Payments.