Balance updates may be delayed
Incident Report for Monzo Bank
Resolved
We've now fixed this and balances should be updating as normal. Thanks for bearing with us and apologies for any inconvenience!
Posted Oct 04, 2018 - 17:28 UTC
Identified
All payments are working as usual and any transfers or top-ups are available to use straight away - this is only affecting the balance displayed in the app. We are currently working on a fix.
Posted Oct 04, 2018 - 17:13 UTC
Investigating
We're currently investigating an issue where changes to your balance are not immediately shown in the app. All payments are working as usual, we'll let you know as soon as we've resolved the issue.
Posted Oct 04, 2018 - 16:54 UTC