Duplicate Transactions
Incident Report for Monzo Bank
Resolved
All duplicate transactions have been refunded. Thank you for your patience.
Posted Oct 01, 2018 - 11:58 UTC
Update
Most of the duplicated payments have now been refunded. We're working with the merchants and their banks to refund the remaining payments, and we'll let you know as soon as we have an update!
Posted Sep 07, 2018 - 18:54 UTC
Identified
This morning some merchants have submitted duplicate payments. We will be working with these merchants and their bank to refund these payments and will keep you updated.
Posted Aug 31, 2018 - 09:14 UTC