Duplicate payments for some merchants
Incident Report for Monzo Bank
Resolved
This incident has been resolved.
Posted Jun 13, 2019 - 17:45 UTC
Identified
This morning some merchants were identified as submitting duplicate payments. We will be working with these merchants and their banks to refund these payments and will keep you updated.
Posted Jun 05, 2019 - 01:36 UTC
This incident affected: 💳 Card Payments.