Declined card payments showing as successful
Incident Report for Monzo Bank
Resolved
All incorrect charges relating to yesterday's Mastercard outage have now been refunded
Posted Jul 13, 2018 - 16:47 UTC
Identified
You may be seeing delayed charges following your card being declined yesterday.

If you haven't already, you should see refunds for these charges shortly.
Posted Jul 13, 2018 - 10:35 UTC
This incident affected: 💳 Card Payments.