Inbound and outbound bank transfers may fail or be delayed.
Incident Report for Monzo Bank
Resolved
This incident has been resolved.
Posted Apr 23, 2018 - 12:57 UTC
Monitoring
In and outbound bank transfers to Monzo should now be functioning as normal, although some earlier payments may still be delayed. We're continuing to monitor this closely.
Posted Apr 23, 2018 - 11:37 UTC
Update
We are currently investigating an issue that is causing some in and outbound bank transfers to fail or be delayed. We will update you as soon as the problem has been resolved. We can't apologise enough for the trouble caused.
Posted Apr 23, 2018 - 10:41 UTC
Investigating
We are currently investigating an issue that has caused some in and outbound bank transfers to fail or be delayed. We will update you as soon as the problem has been resolved. We can't apologise enough for the trouble caused.
Posted Apr 23, 2018 - 10:28 UTC