Bank transfers under maintenance
Incident Report for Monzo Bank
Resolved
We've completed maintenance on our bank transfer systems. All delayed payments have been processed. Thank you for your patience.
Posted Sep 10, 2018 - 16:13 UTC
Identified
We’re currently performing scheduled maintenance on our bank transfer systems. Inbound and outbound payments may be delayed but all payments will be processed as soon as we have completed maintenance. Customers should not retry inbound or outbound transfers. Thank you for your patience.
Posted Sep 10, 2018 - 16:02 UTC
This incident affected: 💰 Inbound Bank Transfers and 💸 Outbound Bank Transfers.