Payment notifications are temporarily delayed
Incident Report for Monzo Bank
Resolved
We've been monitoring the issues closely and are glad to update that we're back up and running as normal now 🎉

As ever we'll continue to keep a close eye on things.
Posted Mar 11, 2018 - 15:18 UTC
Monitoring
We have resolved the issues preventing you from refreshing your feed and using your Monzo app. Delayed feed items from 11:52 and 12:08 are now being delivered.
Posted Mar 11, 2018 - 12:33 UTC
Identified
We’re experiencing problems with transaction notifications. Your card will continue to work, but your feed and balance will not update, and top ups may be delayed. We’re working hard to fix it as soon as we can and will continue to post updates.
Posted Mar 11, 2018 - 12:09 UTC