Card payments, transfers, and top ups are now processing as normal.
Incident Report for Monzo Bank
Resolved
The issues that we were experiencing earlier have been resolved πŸŽ‰ Card payments, transfers, and top ups are now processing as normal.
Posted Mar 17, 2018 - 01:31 UTC
Monitoring
The primary issues that we were experiencing earlier have been resolved πŸŽ‰ Card payments, transfers, and top ups are now processing as normal. Some app features, such as spending categories, may be slow to update while our system recovers πŸ› 
Posted Mar 17, 2018 - 01:04 UTC
Update
We are working to resolve some ongoing issues with the Monzo app. Card payments, bank transfers, and top ups may fail. We will keep you updated on our progress πŸ› 
Posted Mar 16, 2018 - 23:44 UTC
Investigating
We are working to resolve some ongoing issues with the Monzo app. Card payments, bank transfers, and top ups may fail. We will keep you updated on our progress πŸ› 
Posted Mar 16, 2018 - 23:27 UTC