Apple Pay registrations failing or delayed.
Incident Report for Monzo Bank
Resolved
This incident has been resolved.
Posted May 21, 2018 - 14:03 UTC
Investigating
We are currently investigating an issue that is causing Apple Pay registrations to fail or be delayed. We will update you as soon as the problem has been resolved. We can't apologise enough for the trouble caused.
Posted May 21, 2018 - 13:07 UTC